Galaxietool Bug Tracker - Toolbar
View Issue Details
0000745Toolbar(No Category)public2016-03-29 23:152016-04-27 22:27
supermopf 
eX0du5 
normalminoralways
resolvedfixed 
 
 
 
Firefox 45.0.1
0000745: Zerstörte Einheiten werden nicht aus dem KB erkannt
Wenn Einheiten zerstört werden, werden diese nicht erkannt.

Einen KB im Detail öffnen.
Version 2.7.8
No tags attached.
Issue History
2016-03-29 23:15supermopfNew Issue
2016-03-30 16:55eX0du5Assigned To => eX0du5
2016-03-30 16:55eX0du5Statusnew => assigned
2016-03-30 17:16eX0du5Note Added: 0001701
2016-03-30 17:16eX0du5Statusassigned => feedback
2016-03-30 18:22supermopfNote Added: 0001703
2016-03-30 18:22supermopfStatusfeedback => assigned
2016-03-30 21:03eX0du5Note Added: 0001704
2016-04-01 20:18eX0du5Note Added: 0001705
2016-04-01 20:18eX0du5Statusassigned => feedback
2016-04-27 22:27eX0du5Statusfeedback => resolved
2016-04-27 22:27eX0du5Resolutionopen => fixed

Notes
(0001701)
eX0du5   
2016-03-30 17:16   
Was meinst du fehlt?
Schau mal bitte hier in die Schemadefinition was überhaupt an das Galaxietool übertragen wird für Kampfberichte. http://www.galaxytool-hosting.eu/galatool_RD/secret/xml_schema/combat_report.xsd [^]
Da ist nichts von LostUnits dabei. Es gibt nur das Trümmerfeld und die Resourcen. Aber keine Informationen über die Anzahl der zerstörten Einheiten.
Daher funktioniert die Toolbar so wie angedacht.

Im Zuge der Untersuchung fiel mir aber auf, dass im Firefox die Uhrzeit sowie die Koordinaten falsch erkannt wurden. Das habe ich dann eben behoben (mit dem nächsten Update bei Mozilla).
(0001703)
supermopf   
2016-03-30 18:22   
Wie wärs mit:
Line 57 "<xs:attribute name="lost_units" type="integer_with_zero"/>"

Aber es gibt ja nicht umsonst das Feld Einheiten verloren in den KB's im Tool, oder?
(0001704)
eX0du5   
2016-03-30 21:03   
Oh man I must have been blind, or tired, or both. I read the XSD twice before making this posting :-(
Anyway, I will keep it on my name until I am awake again ;-)
(0001705)
eX0du5   
2016-04-01 20:18   
Okay, ich habe mir den KB jetzt genauer angesehen und erinnere mich, dass ich die "lost_unit" bei OGame V6 nicht mehr fülle, da sie nicht mehr angezeigt werden. Früher standen diese im KB direkt neben dem Ausgang der Schlacht.
Es ist theoretisch möglich diese anhand der zerstörten Einheiten aufzuaddieren, ich hatte diesen Aufwand aber nicht betreiben wollen.